Cara Block Torrent dengan layer7 di mikrotik


bagaimana cara block p2p Torrent dengan mikrotik , kalau tidak di block misalnya torrent ini di limit apakah bias ? sebenarnya bisa juga traffic torrent di limit , tetapi tentunya akan banyak memakan resource mikrotik yang banyak, karena menggunakan layer 7

Secara garis besar ada 3 langkah block torrent dengan mikrotik menurut versi saya,  karena selain versi saya masih banyak cara-cara lain yang mungkin bisa digunakan.

  1. Detect src-address user yang menggunakan torrent dengan l7 , terus masukan dalam address-list=user-torrent
  2. Block udp port selain 53 dari user yang terdetect di address-list user-torrent
  3. Kalau mau kurang puas block sekalian port tcp selain 80,443 dari user di address-list user-torrent

Sebelum kita lanjutkan , perlu di ketahui interface pada mikrotik saya yang mengarah ke lokal / switch adalah ether2 pada dan saya ganti nama menjadi ether2-lokal.

Langkah-langkahnya

Download dulu kumpulan layer7-protocol untuk mikrotik.

1. Buka new terminal

/tool fetch url="http://www.mikrotik.com/download/l7-protos.rsc" mode=http

2. Masih di terminal import file l7-protos.rsc sehingga nantinya masuk ke firewall layer7 protocol

/import l7-protos.rsc

3. Detect src-address user yang menggunakan torrent dengan l7 , terus masukan dalam address-list=user-torrent

/ip firewall filter 
add chain=forward in-interface=ether2-lokal layer7-protocol=bittorrent action=add-src-to-address-list address-list=user-torrent  address-list-timeout=1h

itu satu rule untuk bittorrent karena P2P tidak hanya bittorent bisa saja di tambahkan yang lainnya seperti edonkey, gnutella dan lain-lainnya.

4. lanjut rule untuk block

UDP:

/ip firewall filter add chain=forward protocol=udp in-interface=ether2-lokal dst-port=!53 src-address-list=user-torrent action=drop

dengan rule di atas mestinya client torrent sudah tidak berfungsi di tandai icon di torrent client pada pojok kanan bawah berwarna kuning dan ada tanda seru.

5. Kalau masih kurang yakin sekalian di tambahin block port tcp

TCP:

/ip firewall filter add chain=forward protocol=tcp in-interface=ether2-lokal dst-port=!80,443 src-address-list=user-torrent action=drop

User masih bisa browsing tapi tidak bisa menggunakan layanan yang menggunakan port selain port udp 53 dan port tcp 80,443 .

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s