Memblokir Situs Youtube Pada Jam 08:00 sampai 12:00 dan mengaktifkan di hari minggu


Memblokir  Situs Youtube Pada Jam 08:00 sampai 12:00 dan mengaktifkan di hari minggu

/system ntp client set primary-ntp=203.160.128.6 secondary-ntp=202.169.224.16 \ mode=unicast enabled=yes

Kedua, membuat rule di firewall filter. Dalam hal ini saya ingin memblokir situs Facebook yang menggunakan port HTTP (80), sehingga selain port tersebut masih diijinkan. Tujuannya agar pengguna masih dapat menerima update status facebook melalui email. Untuk mensettingnya ketikkan perintah berikut :

/ip firewall filter add chain=forward src-address=0.0.0.0/0 protocol=tcp \ dst-port=80 content=”youtube” action=drop comment=”Blokir Aksesyoutube “;

Ketiga, membuat script untuk mengaktifkan firewall tersebut selama jam kerja dan mematikannya pada jam istirahat dan diluar jam kerja. Disini saya membuat 3 script, yaitu script untuk mengaktifkan (enable) firewall, script untuk mematikan (disable) firewall serta script untuk dieksekusi pada hari libur (Sabtu-Minggu) dan hari kerja. Berikut ini scriptnya :

Script untuk mematikan (disable) firewall :

/system script add name=”fb-allow” policy=write,read,policy,test,sniff source={/ip firewall filter set [/ip firewall filter find content=”youtube”] disabled=yes

Script untuk mengaktifkan (enable) firewall :

/system script add name=”fb-deny” policy=write,read,policy,test,sniff source={/ip firewall filter set [/ip firewall filter find content=”youtube”] disabled=no}

Keempat, membuat schedule untuk menentukan kapan firewall tersebut akan diaktifkan atau dinon-aktifkan. Disini saya membuat 6 scheduler berdasarkan jam kerja dan hari kerja, yaitu jam 08:00 sampai  jam 12:00 Berikut ini scriptnya :

Schedule untuk mengaktifkan (enable) firewall pada jam kerja (08:00) :

/system scheduler add name=”fb-08:00″ start-date=jan/01/2010 start-time=08:00:00 interval=1d on-event=”youtube-deny”

Schedule untuk mematikan (disable) firewall pada jam  (12:00)  dan seterusnya

/system scheduler add name=”youtube-12:00″ start-date=jan/01/2010 start-time=11:30:00 interval=1d on-event=”youtube-allow”

Schedule untuk mematikan (disable) firewall di hari libur (Sabtu-Minggu) :

/system scheduler add name=”youtube-sabtu-minggu” start-date=aug/01/2009 start-time=08:05:00 interval=7d on-event=”youtube-allow”


Pastikan bahwa tanggal yang didefinisikan pada parameter “start-date” scheduler adalah Hari Sabtu. Dan parameter “interval” diberi nilai 7d.

Semoga membantu,Click here to enlarge

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s